Stellar RPC Ingestion Issues and Downtime

Incident Report for Stellar.org

Resolved

This incident has been resolved.
Posted Feb 22, 2026 - 14:12 UTC

Monitoring

We have a fix for the RPC issue in stellar-rpc v25.0.1. You can restore service now if you install via:

our official docker image: https://hub.docker.com/layers/stellar/stellar-rpc/25.0.1
building from source: https://github.com/stellar/stellar-rpc/releases/tag/v25.0.1
Posted Feb 21, 2026 - 00:51 UTC

Identified

The issue has been identified and a fix has been validated, we're currently working on releasing a patch.
Posted Feb 21, 2026 - 00:15 UTC

Investigating

We’re currently investigating an issue that is causing downtime for Stellar RPC, all instances are affected. The Stellar network itself is operating normally and no funds are at risk. We're actively looking into this and we’ll share updates here as soon as we have more information.
Posted Feb 20, 2026 - 20:57 UTC