Latency issues in horizon.stellar.org cluster
Incident Report for Stellar.org
Resolved
This issue has now been resolved, all systems are fully operational.
Posted Oct 29, 2019 - 22:40 UTC
Monitoring
Service has been restored and we are still investigating.
Posted Oct 29, 2019 - 20:20 UTC
Investigating
We are investigating renewed API failure rates.
Posted Oct 29, 2019 - 19:50 UTC
Monitoring
We have failed over to our standby cluster, the new cluster is successfully ingesting and serving requests.

We will continue to monitor the situation.
Posted Oct 29, 2019 - 19:38 UTC
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Oct 29, 2019 - 19:29 UTC
This incident affected: SDF Public Network Horizon.